Minimum Requirements of Supported Browsers Humanity HelpDesk - Minimum Requirements of Supported Browsers

Popular help topics: Scheduling, Setup, Time Clock, Leave Request

Minimum Requirements of Supported Browsers


From your Android phone, Computer, iPhone or iPad     Applies to Managers, Supervisors, Schedulers, Employees


Overview

This article lists the minimum requirements to use Humanity App on your Computer, iPhone/iPad, or Android phone.


Computer (via the web app)

The Humanity web app supports the following internet browsers running on Windows or macOS:

  1. Google Chrome version 49+

  2. Firefox version 48+

  3. Safari version  10+

  4. Internet Explorer version 11+

  5. Microsoft Edge 15+

Note: We recommend to use the latest version.


iPhone or IPad

  • Your iPhone or iPad must be running iOS 10 or later.
  • iOS versions 1.0 - 1.4.2 can continue to use older versions of the Humanity app, but will not have new features or updates. The recommended version is 1.4.3.

Download the App

Make sure to download the app from the App Store as our web app is not supported by mobile web browsers.


Android Phone

  • Your Android phone must be running Android version 4.4 or later.
  • Android versions before 1.4.3 can continue to use older versions of the Humanity app, but will not receive new features or updates.

Download the App

Make sure to download the app from the Google Play Store store as our web app is not supported by mobile web browsers.

If you have any queries, please don't hesitate to reach us at support@humanity.com. Happy Scheduling!